Yes.

You read that right. I’m finally ditching my 2006ish design and will be updating to a more common flow than the deprecated blog-style (although it fits, er, my blog quite well).

I discovered several plugins I have used are not PHP7 compliant, and I don’t know how many I really wish to maintain- I gave up my own homebrew blog software in favor of TextPattern over a decade ago to avoid having to maintain my own code; I no longer had the time or inclination.

It might actually be time to rebuild with a new code base, rather than keeping these older tools running.